You have been given a positive integer N. You need to find and print the Factorial of this number. The Factorial of a positive integer N refers to the product of all number in the range from 1 to N. You can read more about the factorial of a number here.
Input Format:
The first and only line of the input contains a single integer N denoting the number whose factorial you need to find.
Output Format
Output a single line denoting the factorial of the number N.
Constraints
Input Format:
The first and only line of the input contains a single integer N denoting the number whose factorial you need to find.
Output Format
Output a single line denoting the factorial of the number N.
Constraints
SAMPLE INPUT
2
SAMPLE OUTPUT
2
Solution-
import java.util.*;
class Fact{
public static void main(String[] args) {
int fact=1;
Scanner sc=new Scanner(System.in);
int n=sc.nextInt();
for(int i=1;i<=n;i++)
{
fact=fact*i;
}
System.out.println(fact);
}
}
Post a Comment