There are three planes AB and C. Plane A will takeoff on every pth day i.e. p2p3p and so on. Plane B will takeoff on every qth day and plane C will takeoff on every rth day. There is only one runway and the takeoff timing is same for each of the three planes on each day. Your task is to find out the maximum number of flights that will successfully takeoff in the period of N days.
Note: If there is collision between the flights no flight will take off on that day.
Input Format
The first line of the input contains a single integer T, the number of test cases.
Then T lines follow each containing four space-separated integers Npq and r as denoted in the statement.
Output Format
For each test case print a single integer representing the maximum number of flights that will successfully takeoff in the period of N days.
Constraints
1T10
1N,p,q,r105
SAMPLE INPUT
2
10 2 3 4
10 2 2 4
SAMPLE OUTPUT
4
0
Explanation
Sample test case 1:
Note that on days 2 and 10 plane A can takeoff, on days 3 and 9 plane B can takeoff.
Sample test case 2:
Note that there is no day on which there is no collision.




Solution-



import java.util.*;
class Takeoff{
   public static void main(String[] args) {
      Scanner sc=new Scanner(System.in);
int num=sc.nextInt();

int n,p,q,r,count;
for(int i=0;i<num;i++)
{
n=sc.nextInt();
p=sc.nextInt();
q=sc.nextInt();
r=sc.nextInt();
count = 0;
for(int j=1;j<=n;j++)
{
if(j%p == 0 && j%q != 0 && j%r != 0 ||
j%p != 0 && j%q == 0 && j%r != 0 ||
j%p != 0 && j%q != 0 && j%r == 0)
{
count++;
}
}
System.out.println(count);
}
}
}

Post a Comment

Previous Post Next Post