Akash and Vishal are quite fond of travelling. They mostly travel by railways. They were travelling in a train one day and they got interested in the seating arrangement of their compartment. The compartment looked something like
So they got interested to know the seat number facing them and the seat type facing them. The seats are denoted as follows :
INPUT
First line of input will consist of a single integer T denoting number of test-cases. Each test-case consists of a single integer N denoting the seat-number.
OUTPUT
For each test case, print the facing seat-number and the seat-type, separated by a single space in a new line.
CONSTRAINTS
So they got interested to know the seat number facing them and the seat type facing them. The seats are denoted as follows :
- Window Seat : WS
- Middle Seat : MS
- Aisle Seat : AS
INPUT
First line of input will consist of a single integer T denoting number of test-cases. Each test-case consists of a single integer N denoting the seat-number.
OUTPUT
For each test case, print the facing seat-number and the seat-type, separated by a single space in a new line.
CONSTRAINTS
- 1<=T<=105
- 1<=N<=108
SAMPLE INPUT
2 18 40
SAMPLE OUTPUT
19 WS 45 AS
Solution-
import java.util.Scanner;
class Sitting
{
public static void main(String... args)
{
Scanner sc=new Scanner(System.in);
int i,n,rem=0,a;
a=sc.nextInt();
//int arr[]=new int[n];
for(i=0;i<a;i++)
{
n=sc.nextInt();
rem=n%12;
switch(rem)
{
case 0 : n-=11;
System.out.println(n+" "+"WS");
break;
case 1 : n+=11;
System.out.println(n+" "+"WS");
break;
case 2 : n+=9;
System.out.println(n+" "+"MS");
break;
case 3 : n+=7;
System.out.println(n+" "+"AS");
break;
case 4 : n+=5;
System.out.println(n+" "+"AS");
break;
case 5 : n+=3;
System.out.println(n+" "+"MS");
break;
case 6 : n+=1;
System.out.println(n+" "+"WS");
break;
case 7 : n-=1;
System.out.println(n+" "+"WS");
break;
case 8 : n-=3;
System.out.println(n+" "+"MS");
break;
case 9 : n-=5;
System.out.println(n+" "+"AS");
break;
case 10 : n-=7;
System.out.println(n+" "+"AS");
break;
case 11 : n-=9;
System.out.println(n+" "+"MS");
break;
}
}
}
}
Post a Comment